iDEAL outage identified

Incident Report for MultiSafepay

Resolved

The incident has been resolved by the scheme. Our team will monitor the situation but resolve the incident.

For more details:
https://availability.ideal.nl/
Posted Mar 25, 2026 - 15:47 CET

Update

The issue now looks contain to issuer Rabobank
Posted Mar 25, 2026 - 15:43 CET

Identified

A full outage of iDEAL has been identified. We are awaiting resolution by the scheme.

For more details
https://availability.ideal.nl/
Posted Mar 25, 2026 - 15:40 CET
This incident affected: Payments.