EXTERNAL - KBC: Full disruption

Incident Report for MultiSafepay

Resolved

The incident at KBC was resolved around 08:00 CEST. Transaction processing has since returned to normal, with conversions performing as expected.
Posted Oct 07, 2025 - 09:29 CEST

Identified

An incident has been identified at KBC, resulting in a failure to process KBC payments since 10:52 CEST We are currently awaiting further updates from KBC regarding the resolution of the issue.

Further communication will follow as soon as more information becomes available.
Posted Oct 06, 2025 - 11:31 CEST
This incident affected: Payments.