MultiSafepay Dashboard - degraded performance

Incident Report for MultiSafepay

Resolved

The incident has been resolved.
Payment processing has not been affected.
Posted Dec 27, 2022 - 15:40 CET

Identified

We are currently investigating an incident with the MultiSafepay Dashboard transaction overview.
Payment processing is not affected.
Posted Dec 27, 2022 - 15:06 CET
This incident affected: MultiSafepay account dashboard.