Mastercard transactions impacted - Increase in error rate
Incident Report for MultiSafepay
Resolved
Since 09:20 CET the Mastercard transactions are operating under normal rates. An investigation is being carried out to the cause of the issue.
We will keep monitoring closely for the coming hours.
Posted Feb 17, 2021 - 09:38 CET
Investigating
We are currently investigating an issue with Mastercard transactions as we're experiencing elevated error rates. Not all Mastercard transactions are affected.

Our team will update as soon as an update is available on the situation and resolution.
Posted Feb 17, 2021 - 09:19 CET
This incident affected: Payments.