[Bancontact] Major disruption in payment success rate

Incident Report for MultiSafepay

Resolved

The incident has been resolved as per 08:59 CET. Our team will further monitor but close the incident.
Posted Feb 11, 2025 - 09:05 CET

Investigating

We are actively investigating reports of Bancontact payment success rate issues. We will provide an update as soon as more information becomes available.
Posted Feb 11, 2025 - 08:57 CET
This incident affected: Payments.