Apple Pay disruption - payment conversion affected
Incident Report for MultiSafepay
Resolved
The incident has been resolved by Apple Pay, we're seeing regular conversion levels again.
Posted Oct 16, 2023 - 15:23 CEST
Monitoring
We're awaiting a fix to be deployed by Apple Pay.
For some more details: https://www.apple.com/nl/support/systemstatus/
Posted Oct 16, 2023 - 15:08 CEST
Identified
Apple Pay is experiencing a full disruption originating from outside of our platform. We're awaiting resolution by Apple Pay.
Posted Oct 16, 2023 - 14:02 CEST
This incident affected: Payments.