iDEAL performance issues identified at issuer Rabobank

Incident Report for MultiSafepay

Resolved

The incident has been resolved. We'll monitor the situation closely in case of a flare-up.
Posted Nov 03, 2023 - 12:21 CET

Identified

iDEAL issuer Rabobank is experiencing significant conversion issues, MultiSafepay is standing by on resolution by issuer.
For more details

https://beschikbaarheid.ideal.nl/History?bank=Rabobank
Posted Nov 03, 2023 - 12:02 CET
This incident affected: Payments.