iDEAL performance issues identified at issuer ING
Incident Report for MultiSafepay
Resolved
The incident has been resolved by the issuer ING.
Posted Jun 10, 2024 - 09:34 CEST
Monitoring
The incident has been resolved by ING, we'll be monitoring the situation for now.

Fore more details: https://beschikbaarheid.ideal.nl/History?bank=ING
Posted Jun 10, 2024 - 09:21 CEST
Identified
iDEAL issuer ING is experiencing significant conversion issues, MultiSafepay is standing by on resolution by issuer.
For more details check

https://beschikbaarheid.ideal.nl/History?bank=ING
Posted Jun 10, 2024 - 09:02 CEST
This incident affected: Payments.