iDEAL performance issues identified at issuer Rabobank

Incident Report for MultiSafepay

Resolved

The incident has been resolved.

For more details
https://availability.ideal.nl/
Posted Jun 01, 2026 - 09:49 CEST

Identified

There are identified performance issues with iDEAL payments at Rabobank, we are awaiting resolution by the issuer.

For more details:
https://availability.ideal.nl/
Posted Jun 01, 2026 - 09:28 CEST
This incident affected: Payments.