iDEAL performance issues identified at issuer Rabobank
Incident Report for MultiSafepay
Resolved
The incident has been resolved.
Posted Sep 07, 2023 - 09:44 CEST
Identified
Several iDEAL issuers are experiencing (partial) outages, amongst them Rabobank and SNS.
We are awaiting resolution of these issues from these parties.

For more details: https://beschikbaarheid.ideal.nl/
Posted Sep 07, 2023 - 08:07 CEST
Investigating
iDEAL transactions are impacted by a lower conversion at Rabobank, our team is currently investigating the cause.
We will provide updates on status and cause as they come available.
Posted Sep 07, 2023 - 07:51 CEST
This incident affected: Payments.