ING is experiencing performance issues - iDEAL transactions impacted
Incident Report for MultiSafepay
Resolved
The incident has been resolved by ING. We’ll monitor the situation closely
Posted Jun 07, 2021 - 18:29 CEST
Identified
ING is reporting issues with processing iDEAL transactions. Our team is monitoring the situation closely and will update when new information becomes available.

For more information regarding the availability of iDEAL:
https://beschikbaarheid.ideal.nl/
Posted Jun 07, 2021 - 12:18 CEST
This incident affected: Payments.