ABN AMRO is experiencing performance issues - iDEAL transactions impacted
Incident Report for MultiSafepay
Resolved
ABN AMRO has resolved their issue and we have seen performance return to normal levels since 10:50 CEST.
Posted May 23, 2022 - 11:17 CEST
Identified
ABN AMRO is reporting high error rates, we are currently monitoring the situation as it resides at ABN AMRO. We'll update once there is an update.
More information: https://beschikbaarheid.ideal.nl/History?bank=ABN_AMRO
Posted May 23, 2022 - 09:46 CEST
This incident affected: Payments.