Bancontact performance degradation
Incident Report for MultiSafepay
Resolved
This incident has been resolved by Bancontact and we’re seeing over the last period normal conversion rates again. Our team will monitor the situation but close this incident.
Posted Mar 22, 2022 - 22:33 CET
Investigating
Bancontact is experiencing a high error rate and lower conversion. Our team is currently monitoring the situation as the issue lies with Bancontact, once an update is available we'll update this status page.
Posted Mar 22, 2022 - 20:09 CET
This incident affected: Payments.