iDEAL performance issues identified at issuer Rabobank
Incident Report for MultiSafepay
Resolved
The incident has been resolved by the issuer
Posted Sep 04, 2024 - 13:46 CEST
Identified
We have identified a performance drop in iDEAL payment with issuer Rabobank, we're monitoring the situation.

For more details check:
https://beschikbaarheid.ideal.nl/
Posted Sep 04, 2024 - 12:35 CEST
This incident affected: Payments.