iDEAL performance issues with ING
Incident Report for MultiSafepay
Resolved
The incident appears to have been resolved by ING around 16:00 CEST. We're closing the incident for now.

For more details:
https://beschikbaarheid.ideal.nl/
Posted Jun 02, 2023 - 16:21 CEST
Identified
ING is experiencing performance issues with handling iDEAL, we're currently monitoring the situation and awaiting resolution by ING. Other issuers are not affected at this point.

For more details:
https://beschikbaarheid.ideal.nl/History?bank=ING
Posted Jun 02, 2023 - 13:30 CEST
This incident affected: Payments.