iDEAL performance degradation
Incident Report for MultiSafepay
Resolved
The incident seems to be resolved. We'll keep on monitoring the situation closely but we'll resolve the incident for now.
Posted Jul 22, 2021 - 19:05 CEST
Monitoring
iDEAL issuers ABN AMRO and RABOBANK are experiencing full outages which appear to be linked to a more global outage of systems.
We are monitoring the situation and will report back when the issues have been resolved.

For more information please also refer to https://beschikbaarheid.ideal.nl/
Posted Jul 22, 2021 - 18:31 CEST
Identified
iDEAL issuers ABN AMRO and RABOBANK are experiencing severe performance degradations.
We are currently monitoring the situation.

For more information please also refer to https://beschikbaarheid.ideal.nl/
Posted Jul 22, 2021 - 18:11 CEST
This incident affected: Payments.