Cloudflare Supplier Incident - No payment performance impact

Incident Report for MultiSafepay

Resolved

We’re closing this issue as we haven’t observed any further incidents. Cloudflare is still reporting some issues on their side that are affecting parts of their global infrastructure.
Posted Nov 18, 2025 - 16:32 CET

Monitoring

The service has been resolved, we're currently monitoring the situation before closing the incident at Cloudflare.
Posted Nov 18, 2025 - 13:19 CET

Identified

We are currently aware of an issue affecting our upstream supplier, Cloudflare, which is experiencing a service disruption. As a result, some of our customers may encounter intermittent performance issues or connectivity problems with connecting to our Dashboard.

Do note that there is no impact on payment processing.

Our team is actively monitoring the situation and working with Cloudflare to ensure services are restored to normal as quickly as possible.
Posted Nov 18, 2025 - 13:12 CET
This incident affected: MultiSafepay account dashboard.