iDEAL performance issues with ING
Incident Report for MultiSafepay
Resolved
The incident looks resolved by ING. We’ll close the incident but continue to monitor closely.
Posted Oct 31, 2022 - 19:31 CET
Investigating
iDEAL is experiencing severe issues with again today processing ING bank transactions . This issue is outside of our platform and we're awaiting resolution by ING or iDEAL. For more information; https://availability.ideal.nl/
Posted Oct 31, 2022 - 16:05 CET
This incident affected: Payments.