iDEAL performance issues with ING
Incident Report for MultiSafepay
Resolved
This incident has been resolved.
Posted May 12, 2023 - 13:31 CEST
Update
We are continuing to investigate this issue.
Posted May 12, 2023 - 13:30 CEST
Investigating
An issue has been identified at iDEAL issuer ING, we're awaiting resolution by ING.
For more details: https://beschikbaarheid.ideal.nl/
Posted May 12, 2023 - 12:46 CEST
This incident affected: Payments.