iDEAL performance issues identified at issuer ABN AMRO
Incident Report for MultiSafepay
Resolved
The incident has been resolved by ABN AMRO.
Posted Aug 20, 2024 - 10:38 CEST
Monitoring
Performance levels have returned to within regular, we're monitoring the situation.


For more details check:
https://beschikbaarheid.ideal.nl/
Posted Aug 20, 2024 - 09:45 CEST
Identified
We have identified a performance drop in iDEAL payment with issuer ABN AMRO, we're monitoring the situation awaiting resolution on their side.

For more details check:
https://beschikbaarheid.ideal.nl/
Posted Aug 20, 2024 - 09:29 CEST
This incident affected: Payments.