iDEAL performance degradation
Incident Report for MultiSafepay
Resolved
This incident has been resolved.
Posted Jul 24, 2024 - 12:26 CEST
Monitoring
A fix has been implemented by iDEAL and we are monitoring the results.
Posted Jul 24, 2024 - 10:34 CEST
Update
We continue standing by for a resolution from iDEAL.
Posted Jul 24, 2024 - 10:13 CEST
Identified
iDEAL is experiencing general conversion issues across multiple issuers. MultiSafepay is standing by for a resolution from iDEAL.
Posted Jul 24, 2024 - 10:12 CEST
This incident affected: Payments.