Degraded performance warning - partial outage
Incident Report for MultiSafepay
Resolved
The incident has been resolved, all systems are reporting nominal performance.
Posted Feb 21, 2022 - 21:09 CET
Update
We are escalating the status warning as the issue is affecting multiple areas. Our team will update as we progress
Posted Feb 21, 2022 - 21:03 CET
Investigating
We are currently experiencing performance degradation on our Merchant Control
Posted Feb 21, 2022 - 20:59 CET
This incident affected: API, Payments, MultiSafepay payment pages, MultiSafepay account dashboard, and MultiSafepay app.