iDEAL performance issues with ING
Incident Report for MultiSafepay
Resolved
The incident appears resolved since 13:30 CET.
For more details: https://availability.ideal.nl/
Posted Nov 07, 2022 - 13:55 CET
Identified
iDEAL is experiencing severe issues with again today processing ING bank transactions . This issue is outside of our platform and we're awaiting resolution by ING or iDEAL. For more information; https://availability.ideal.nl/
Posted Nov 07, 2022 - 12:21 CET
This incident affected: Payments.