Notification delivery performance degradation

Incident Report for MultiSafepay

Resolved

The incident has been resolved and previously failed notifications have been resent.
Posted Jul 05, 2026 - 12:15 CEST

Monitoring

A fix has been implemented and we are monitoring at this point
Posted Jul 05, 2026 - 11:16 CEST

Identified

An decrease in delivery success has been spotted on our platform. Our team is investigating the root cause.
Posted Jul 05, 2026 - 10:48 CEST
This incident affected: API and Payments.