Major performance degradation of Bancontact payments

Incident Report for MultiSafepay

Resolved

The incident has been resolved outside of our infrastructure.
Posted May 20, 2026 - 15:44 CEST

Monitoring

Traffic has returned to regular performance levels, the incident appears outside of our infrastructure. We’ll be monitoring for now.
Posted May 20, 2026 - 15:41 CEST

Investigating

We are currently investigating a major performance degradation of Bancontact payments. Once more information is available we will update
Posted May 20, 2026 - 15:36 CEST
This incident affected: Payments.