Merchant Control Panel is unable to load data - transactions are not affected.
Incident Report for MultiSafepay
Resolved
The incident has been resolved and the Control Panel services have been restored.
Posted Mar 02, 2021 - 13:48 CET
Identified
We have identified that the Merchant Control Panel is unable to load transaction data, our team is currently looking into this.
Transactions themselves are not affected.
Posted Mar 02, 2021 - 13:27 CET
This incident affected: MultiSafepay account dashboard and MultiSafepay app.