iDEAL performance degradation

Incident Report for MultiSafepay

Resolved

iDEAL issuer RABOBANK appears to have resolved their issue with processing iDEAL transactions.
We will keep monitoring the situation closely.

For more information please also refer to https://beschikbaarheid.ideal.nl/
Posted Sep 04, 2021 - 11:48 CEST

Identified

iDEAL issuer RABOBANK is experiencing severe performance degradations.
We are currently monitoring the situation.

For more information please also refer to https://beschikbaarheid.ideal.nl/
Posted Sep 04, 2021 - 10:30 CEST
This incident affected: Payments.