Hosted Payment Page - payment processing performance degradation
Incident Report for MultiSafepay
Resolved
The performance has returned to regular performance levels, our team will keep monitoring but this incident will be closed.
Posted Sep 28, 2022 - 16:24 CEST
Identified
An issue has been identified with the performance of the hosted payment page. The team is currently investigating the cause to resolve the issue.
Posted Sep 28, 2022 - 15:22 CEST
This incident affected: MultiSafepay payment pages.