[Platform] Performance degradation
Incident Report for MultiSafepay
Resolved
The performance has returned to regular levels, our team will closely monitor the situation but for now we're closing this incident.
Posted Oct 21, 2022 - 19:32 CEST
Investigating
We are currently investigating reports of performance issues on the MultiSafepay platform. Conversion rates are below our thressholds and the team is investigating the root cause. We will update this page once more information is available.
Posted Oct 21, 2022 - 18:31 CEST
This incident affected: API, Payments, and MultiSafepay payment pages.