Disruption of platform - payments are affected
Incident Report for MultiSafepay
Resolved
The incident has been resolved and all systems are operational.
Posted Sep 14, 2023 - 10:29 CEST
Identified
We have identified the issue and payments are being accepted again since 10:20 CEST. Full recovery will be achieved shortly.
Posted Sep 14, 2023 - 10:24 CEST
Investigating
Our platform and services are experiencing a full disruption, payments are affected at this point.
We are aware of the situation and our team is investigating, we will update as soon as possible.
Posted Sep 14, 2023 - 10:03 CEST
This incident affected: API, Payments, MultiSafepay payment pages, MultiSafepay account dashboard, MultiSafepay app, and Customer support.