iDEAL performance issues with ABN AMRO
Incident Report for MultiSafepay
Resolved
This incident has been resolved. MultiSafepay will monitor the situation closely in the next couple of hours.
Posted Oct 16, 2020 - 18:23 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 16, 2020 - 16:29 CEST
Investigating
ABN AMRO has reportedly issues with handling iDEAL payments, other banks do not seem to be affected at this point. We're closely monitoring the situation and will update soon.
Posted Oct 16, 2020 - 16:29 CEST
This incident affected: Payments.