iDEAL performance issues identified at issuer ABN AMRO

Incident Report for MultiSafepay

Resolved

The incident has been resolved

For more details check:
https://beschikbaarheid.ideal.nl/
Posted Sep 06, 2024 - 11:18 CEST

Monitoring

We are currently continuing to monitor the situation, although iDEAL has reported the issue as resolved.​

For more details check:
https://beschikbaarheid.ideal.nl/
Posted Sep 06, 2024 - 11:10 CEST

Investigating

We have identified a performance drop in iDEAL payment conversion with issuer ABN AMRO, we're monitoring the situation.

For more details check:
https://beschikbaarheid.ideal.nl/
Posted Sep 06, 2024 - 10:21 CEST
This incident affected: Payments.