iDEAL performance issues identified at issuer Rabobank
Incident Report for MultiSafepay
Resolved
This incident has been resolved at around 15:16.

For more details https://beschikbaarheid.ideal.nl/
Posted Feb 01, 2024 - 15:37 CET
Identified
iDEAL issuer Rabobank is experiencing significant conversion issues, MultiSafepay is standing by on resolution by issuer.
For more details

https://beschikbaarheid.ideal.nl/History?bank=Rabobank
Posted Feb 01, 2024 - 15:05 CET
This incident affected: Payments.