iDEAL performance issues identified

Incident Report for MultiSafepay

Resolved

The incident has been resolved. We'll be monitoring the situation.
Posted Dec 05, 2025 - 10:17 CET

Identified

The issue has been identified.

For more details:

https://availability.ideal.nl/
Posted Dec 05, 2025 - 10:02 CET

Investigating

We have identified a major drop in performance of iDEAL. Currently investigating the root cause.
We will update once more information becomes available
Posted Dec 05, 2025 - 09:58 CET
This incident affected: Payments.