EXTERNAL - iDEAL: Major disruption at ING

Incident Report for MultiSafepay

Resolved

This incident has been resolved.
Posted Jan 08, 2025 - 16:05 CET

Investigating

EXTERNAL - iDEAL: Major disruption at ING
Posted Jan 08, 2025 - 14:13 CET
This incident affected: Payments.