[iDEAL] Multiple issuers are experiencing performance issues

Incident Report for MultiSafepay

Resolved

The incident has been resolved by iDEAL.
Posted Nov 10, 2025 - 12:33 CET

Monitoring

iDEAL has implemented a fix and we're seeing performance improving. We're awaiting further details from iDEAL on resolution.

For more details:
https://availability.ideal.nl/
Posted Nov 10, 2025 - 12:32 CET

Identified

[iDEAL] Multiple issuers are experiencing performance issues and we're awaiting resolution by them.

For more details:
https://availability.ideal.nl/
Posted Nov 10, 2025 - 11:54 CET
This incident affected: Payments.