Belfius - elevated error rate with Belfius payment method

Incident Report for MultiSafepay

Resolved

The incident has been resolved by Belfius. We’ll close the incident.
Posted Apr 13, 2023 - 20:22 CEST

Identified

We have identified the issue(s) and are awaiting resolution by Belfius. The payment method itself is experiencing elevated error rates. We're closely monitoring the situation and will update you as soon as possible
Posted Apr 13, 2023 - 19:52 CEST
This incident affected: Payments.