MultiSafepay Dashboard - partial outage
Incident Report for MultiSafepay
Resolved
The incident has been resolved.
Payment processing has not been affected.
Posted Nov 15, 2022 - 12:54 CET
Investigating
We are currently investigating reports of the MultiSafepay Dashboard being unavailable.
Payment processing is not affected.
Posted Nov 15, 2022 - 12:51 CET
This incident affected: MultiSafepay account dashboard.