iDEAL performance issues with ABN AMRO
Incident Report for MultiSafepay
Resolved
The incident has been resolved by ABN AMRO since 17:20 CET
Posted Nov 15, 2022 - 19:06 CET
Investigating
ABN AMRO is experiencing conversion issues. We're awaiting resolution
For more information: https://beschikbaarheid.ideal.nl/History?bank=ABN_AMRO
Posted Nov 15, 2022 - 16:35 CET
This incident affected: Payments.