Payment method performance degradation - PayPal Transactions

Incident Report for MultiSafepay

Resolved

Transaction processing has remained stable since 18:30 CEST, and no further duplication scenarios have been observed. We’ll continue to monitor closely, but the incident will be closed for now pending any new findings.
Posted Oct 06, 2025 - 19:45 CEST

Investigating

We’ve identified an issue where, in specific scenarios, PayPal transactions are being duplicated. Our team is actively working with PayPal to determine the root cause and implement a resolution.
Posted Oct 06, 2025 - 12:51 CEST
This incident affected: Payments.