iDEAL performance issues with Rabobank
Incident Report for MultiSafepay
Resolved
The incident has been resolved by Rabobank. We’ll closely monitor the situation.
For more information please see

https://beschikbaarheid.ideal.nl/
Posted Feb 23, 2022 - 11:01 CET
Identified
Rabobank is reporting to have issues with handling iDEAL transactions, other banks are unaffected at this point.
We're currently monitoring the situation and will update as new information becomes available.
For more information:
https://beschikbaarheid.ideal.nl/History?bank=Rabobank
Posted Feb 23, 2022 - 10:25 CET
This incident affected: Payments.