iDEAL performance issues identified at issuer ABN AMRO

Incident Report for MultiSafepay

Resolved

The incident has been resolved by the issuer and we're closing the incident.

For more details:
https://availability.ideal.nl/
Posted Feb 09, 2026 - 19:56 CET

Identified

There are identified performance issues with iDEAL payments at ABN AMRO, we are awaiting resolution by the issuer.

For more details:
https://availability.ideal.nl/
Posted Feb 09, 2026 - 19:47 CET
This incident affected: Payments.