[Bancontact] Major disruption in payment success rate
Incident Report for MultiSafepay
Resolved
The incident has been resolved as of 08:00 CET
Posted Oct 16, 2024 - 08:26 CEST
Investigating
A major disruption in payment success rate has been noticed on Bancontact traffic, analysis in progress.
We'll update as soon as more information becomes available.
Posted Oct 16, 2024 - 07:36 CEST
This incident affected: Payments.