Mastercard performance degradation - payment conversion affected
Incident Report for MultiSafepay
Resolved
The incident has been resolved since 11:32 CET. Conversion rates have returned to regular levels.
Our team will remain to closely monitoring the service.
Posted Mar 15, 2023 - 11:46 CET
Identified
The issue is identified to be related with the 3D Secure Directory and is affecting Visa, MasterCard and American Express transactions.
Our team is working on identifying the cause.
Posted Mar 15, 2023 - 11:39 CET
Investigating
Currently we're investigating an issue with MasterCard transactions performing at a lower conversion rate. Investigation is in progress of root cause. We'll update once more information is available
Posted Mar 15, 2023 - 10:13 CET
This incident affected: Payments.