[iDEAL] Issuer Rabobank is experiencing a performance drop

Incident Report for MultiSafepay

Resolved

The incident has been resolved by Rabobank
Posted Dec 03, 2024 - 13:44 CET

Identified

The issue has been identified at Rabobank
Posted Dec 03, 2024 - 13:22 CET

Investigating

We are currently seeing a performance drop in iDEAL transactions from the issuer Rabobank. We are awaiting resolution from Rabobank on these issues.

For more details:
https://availability.ideal.nl/
Posted Dec 03, 2024 - 13:21 CET
This incident affected: Payments.