Bancontact performance degradation
Incident Report for MultiSafepay
Resolved
This incident has been resolved by Bancontact and we’re seeing over the last period normal conversion rates again. Our team will monitor the situation.
Posted Sep 15, 2022 - 19:14 CEST
Investigating
Bancontact is experiencing performance degradation. Our team has identified an issue outside of our platform resulting in a reduced number of approved transactions starting at 15:30 CEST.

The issue is identified at Bancontact and we're awaiting resolution. Once we have received an update we'll update the status page here.
Posted Sep 15, 2022 - 16:49 CEST
This incident affected: Payments.