iDEAL performance issues with ING
Incident Report for MultiSafepay
Resolved
The incident has been resolved as from 13:30 CET
Posted Sep 24, 2021 - 16:05 CEST
Identified
ING is experiencing performance issues since 11:50, we are monitoring the situation and awaiting resolution by ING.
For further details please check https://beschikbaarheid.ideal.nl/
Posted Sep 24, 2021 - 13:13 CEST
This incident affected: Payments.