iDEAL performance issues with ING
Incident Report for MultiSafepay
Resolved
Conversion rates have been returned to normal levels again since 11:20 CEST after a small fallback since the last update. We'll be closing this incident, for more details on the issue at ING:
https://beschikbaarheid.ideal.nl/History?bank=ING
Posted Apr 20, 2022 - 11:33 CEST
Monitoring
We are seeing that conversion rates are returning to normal levels again for ING. We will monitor the situation further and close once fully confirmed and stable.

More details: https://beschikbaarheid.ideal.nl/History?bank=ING
Posted Apr 20, 2022 - 10:51 CEST
Identified
We have identified an increase in error rates from ING - other iDEAL banks seem not to be affected. We are currently monitoring the situation and will report once an update is available.
Posted Apr 20, 2022 - 10:31 CEST
This incident affected: Payments.