iDEAL performance issues identified at issuer ABN AMRO resurfaced
Incident Report for MultiSafepay
Resolved
The incident has been resolved.
Posted Aug 20, 2024 - 12:00 CEST
Identified
The performance of iDEAL issuer ABN AMRO has dropped again, we're monitoring the situation.

For more details: https://availability.ideal.nl/
Posted Aug 20, 2024 - 10:43 CEST
This incident affected: Payments.