Mastercard performance degradation
Incident Report for MultiSafepay
Resolved
Mastercard performance has been stable since 15:30 CET. We continue to monitor the situation closely.
Posted Aug 25, 2021 - 19:11 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 25, 2021 - 08:24 CEST
Investigating
Mastercard is experiencing performance degradation. Our team is currently working on this and will update as soon as possible.
Posted Aug 25, 2021 - 08:24 CEST
This incident affected: Payments.